App crashes when typing in a payee

shaj316shaj316 Posts: 8Member
edited September 2011 in iOS
On 3-4 occassions in the last week (since I downloaded app), it will crash when I am entering a new transaction and typing in the Payee. No error...just closes. When I re-open YNAB app, I'm able to try again and it works fine. Otherwise, app works great. thanks!

btw...could we change the date wheel to a calendar view where I can just click on the date. sort of like when you are looking for a flight on orbitz or united and you click in the date field and a small calendar for that month (or sometimes the next one) will pop up.

Thanks.
Post edited by Unknown User on

Comments

  • BastiBasti Posts: 862Member, Moderator, Administrator, YNAB Team, Beta Tester, Beta Moderator
    Oh wow, I'm sorry that the app is crashing on you! Is there something special about the payees you are searching for when it crashes? Like, maybe some special characters or something like that?
  • shaj316shaj316 Posts: 8Member
    No, the only non-standard character I've used is a dash (7-Eleven) but can't remember if it happened on that one. I want to say it happened once with Panera and maybe another time with Shell Oil. To be more specific, I think it crashes when I the hit the Done button...the screen seems to hang there a second or two before closing down. If it helps, I'm on 4.2.10 (8E600). I was going to plug into iTunes and check for an update but I'll wait if you like.
  • BastiBasti Posts: 862Member, Moderator, Administrator, YNAB Team, Beta Tester, Beta Moderator
    4.2.1? Is that a Verizon iPhone? If so, it would be the second time I've heard about an issue that I can't reproduce on my devices. Dang. I'll look into it!
    Could you please test if this still happens if you disable the geo-smart payees in the settings? Thanks!

    Oh, and no need to wait if you could update, but thanks for the offer.
  • macduncanmacduncan Posts: 620Member, Beta Tester
    Quick message....I have the iPhone and have entered multiple transactions, no issue.

    Bill
  • shaj316shaj316 Posts: 8Member
    Yes, I'm on Verizon. Again, not a big deal. I've entered 30-35 transactions since I downloaded app and it happened 3 or 4 times. I was always able to re-open the app immediately, repeat the transaction entry and it would work fine. In fact, since I posted my initial note, it hasn't happened again. I'll let you know if I see it again and the exact steps. I'm guessing its some kind of memory thing...maybe it's not playing nice with another app.
  • shaj316shaj316 Posts: 8Member
    Okay, just happened again.
    1. Opened YNAB iPhone app.
    2. Clicked on Budget
    3. Clicked on "Drive Thru" subcategory in the Food Master Category
    4. Clicked on the Payee field and payee entry screen popped up.
    5. Began entering McD in the Payee Name field. (yes, I used up arrow for capitalization on M and D. I don't think this matters but being thorough)
    6. Clicked on McDonalds in the results that appeared below.
    7. McDonalds populated the Payee Name field.
    8. App froze and could not click Done.
    9. App closed after approximately 2 seconds.
    10. Reopened app and repeated steps. Worked no problem.

    Thanks,
    Shaj
  • BastiBasti Posts: 862Member, Moderator, Administrator, YNAB Team, Beta Tester, Beta Moderator
    Are you using the GPS feature for the payees? Settings page --> Use GPS?
    Thanks.
  • shaj316shaj316 Posts: 8Member
    No. My setting are all OFF. (Autopopulate memo, Use device region, use gps).

    Shaj
  • shaj316shaj316 Posts: 8Member
    Hey. Now that you guys have updated app, I'm guessing this wont occur again. I've been using the new version since apple offered the update and its worked great. By the way, it looks pretty slick so nice job with that.

    Later!
  • BastiBasti Posts: 862Member, Moderator, Administrator, YNAB Team, Beta Tester, Beta Moderator
    Thanks, we are glad you like it!
    Let me know if this happens again, I made some changes that should fix it, but you never know.
Sign In or Register to comment.